On Thu, Jan 26, 2012 at 1:21 AM, Fujii Masao <masao(dot)fujii(at)gmail(dot)com> wrote:
> On Wed, Jan 25, 2012 at 11:12 PM, Simon Riggs <simon(at)2ndquadrant(dot)com> wrote:
>> On Wed, Jan 25, 2012 at 1:57 PM, Robert Haas <robertmhaas(at)gmail(dot)com> wrote:
>>> I think that this would be a lot more clear if we described this as
>>> synchronous_commit = remote_write rather than just synchronous_commit
>>> = write. Actually, the internal constant is named that way already,
>>> but it's not exposed as such to the user.
>> That's something to discuss at the end of the CF when people are less
>> busy and we get more input.
>> It's an easy change whatever we decide to do.
> Added this to 9.2 Open Items.
OK, so I think it's time to decide what we want to do here. In my
view, remote_write seems a lot more clear than write (since someone
might otherwise think we were talking about a local write) and it has
the additional advantage of matching the internal naming convention -
surely, if it's write to call it SYNCHRONOUS_COMMIT_REMOTE_WRITE
inside the system, then there's not really much reason to drop the
word "remote" on the user-visible side of things. However, I just
work here. Does anyone want to make a counter-argument?
The Enterprise PostgreSQL Company
In response to
pgsql-hackers by date
|Next:||From: Peter Geoghegan||Date: 2012-04-13 17:15:20|
|Subject: Re: Memory usage during sorting|
|Previous:||From: Robert Haas||Date: 2012-04-13 17:00:59|
|Subject: Re: 9.2 release notes, beta time?|
pgsql-committers by date
|Next:||From: Peter Eisentraut||Date: 2012-04-13 17:37:45|
|Subject: pgsql: Consistently quote encoding and locale names in messages|
|Previous:||From: Robert Haas||Date: 2012-04-13 16:47:47|
|Subject: pgsql: Grammar corrections.|