Skip site navigation (1) Skip section navigation (2)

Re: BUG #7485: 9.2 beta3 libxml2 can't be loaded on Windows

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Rikard Pavelic <rikard(dot)pavelic(at)zg(dot)htnet(dot)hr>
Cc: Craig Ringer <ringerc(at)ringerc(dot)id(dot)au>, pgsql-bugs <pgsql-bugs(at)postgresql(dot)org>, Sachin Srivastava <sachin(dot)srivastava(at)enterprisedb(dot)com>, Heikki Linnakangas <heikki(dot)linnakangas(at)enterprisedb(dot)com>
Subject: Re: BUG #7485: 9.2 beta3 libxml2 can't be loaded on Windows
Date: 2012-08-16 13:42:17
Message-ID: (view raw or whole thread)
Lists: pgsql-bugs
On Wed, Aug 15, 2012 at 2:43 PM, Dave Page <dpage(at)pgadmin(dot)org> wrote:
> On Wed, Aug 15, 2012 at 2:37 PM, Rikard Pavelic
> <rikard(dot)pavelic(at)zg(dot)htnet(dot)hr> wrote:
>> On 15.8.2012. 3:54, Craig Ringer wrote:
>>> On 08/14/2012 11:42 PM, Rikard Pavelic wrote:
>>>> On 8.8.2012. 13:30, Craig Ringer wrote:
>>>>> On 08/08/2012 06:24 PM, rikard(dot)pavelic(at)zg(dot)htnet(dot)hr wrote:
>>>>>> The following bug has been logged on the website:
>>>>>> Bug reference:      7485
>>>>>> Logged by:          Rikard Pavelic
>>>>>> Email address:      rikard(dot)pavelic(at)zg(dot)htnet(dot)hr
>>>>>> PostgreSQL version: 9.2 beta3
>>>>>> Operating system:   Windows
>>>>>> Description:
>>>>>> This is still an issue as reported in
>>>>> - How you installed PostgeSQL (ie the EnterpriseDB installer, from source, .zip install)
>>>> I've used EnterpriseDB installer (9.2 beta2 with this bug, and now 9.2 beta3)
>>>>> - The error message you are getting and the command(s) that cause it
>>>> ERROR: could not set up XML error handler
>>>> SQL state: 0A000
>>>> Hint: This probably indicates that the version of libxml2 being used is not compatible with the libxml2 header files that PostgreSQL was built with.
>>>> I'm calling function with type that has an XML attribute.
>>>> I can provide a test case, but since this is just a warning of the old bug I didn't.
>>> OK, I get you.
>>> Given the context of the old report this sounds like it could be an installation/packaging issue. I'll ping the EDB folks.
>>> Which Windows is it exactly? And did you use the 32-bit or 64-bit installer?
>>> --
>>> Craig Ringer
>> Windows 7 64bit
>> PostgreSQL 9.2beta3, compiled by Visual C++ build 1600, 64-bit
> This still seems to be an issue in the test beta4 installers rolled
> this morning. I'm looking into it.

So Sachin and I have looked at this but not found a problem with the
installers. He then found that one of our colleagues has already
reported this as an issue with PostgreSQL and submitted a possible
patch. So, we need a committer to look at fixing this:

Dave Page
Twitter: @pgsnake

EnterpriseDB UK:
The Enterprise PostgreSQL Company

In response to


pgsql-bugs by date

Next:From: Tom LaneDate: 2012-08-16 14:26:27
Subject: Re: BUG #7485: 9.2 beta3 libxml2 can't be loaded on Windows
Previous:From: psqlDate: 2012-08-16 10:15:54
Subject: Re-2: BUG #7495: chosen wrong index

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group