Skip site navigation (1) Skip section navigation (2)

Re: pgAdmin III: the debugger does not pre-populate default values for arguments

From: Nikhil S <nixmisc(at)gmail(dot)com>
To: Dave Page <dpage(at)pgadmin(dot)org>
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: pgAdmin III: the debugger does not pre-populate default values for arguments
Date: 2011-02-12 05:32:14
Message-ID: AANLkTimLxwys7=dRHPd-XB9LR4TRmn6aCTkK4SVhbRwC@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
> > Hmmm, well variables can default to NULL too. The backend code tries to
> > track those variables which default to NULL or to other values. For the
> > rest, it defaults them to "". It then uses construct_md_array to generate
> > the output string for type TEXTOID. Dunno if we can have nothing (an
> empty
> > string) as valid TEXTOID output. I guess it's a limitation for this type.
> > Let me see if we can do something here on the backend side...
>
> Doesn't really help, as we need to ensure it works sanely with
> existing servers too.
>
>
Well it will work with only those servers which support default values for
arguments (PG 8.4 onwards, right?).

But I guess you mean, we should find a solution more on the pgadmin side
instead of tinkering with the backend?

Regards,
Nikhils

In response to

Responses

pgadmin-hackers by date

Next:From: Dave PageDate: 2011-02-12 06:45:11
Subject: Re: pgAdmin III: the debugger does not pre-populate default values for arguments
Previous:From: Peter GeogheganDate: 2011-02-11 20:36:07
Subject: Re: phase 2 of wxWidgets 2.9 build

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group