Skip site navigation (1) Skip section navigation (2)

R: Builds errors with 1.6.3 and wxWidgets 2.8.1 on Ubuntu

From: <massimo_fidanza(at)alice(dot)it>
To: "Jason L(dot) Buberel" <jason(at)buberel(dot)org>,<pgadmin-support(at)postgresql(dot)org>
Subject: R: Builds errors with 1.6.3 and wxWidgets 2.8.1 on Ubuntu
Date: 2007-05-10 12:20:52
Message-ID: 9939E6018058714687D806A98710D51C01A3DC76@FBCMST05V01.fbc.local (view raw or flat)
Thread:
Lists: pgadmin-support
Hi,

I had the same problem. And I have a patch that solve it.
The pgagent need to be linked with wx core library too.
To apply the patch go into the pgadmin source folder and run

patch -p0 < acinclude.m4.diff

After that the bootstrap script need to be reexecuted

sh bootstrap

and the configure too

./configure

You are done, now pgadmin will build without problem.


Massimo

-----Messaggio originale-----
Da: pgadmin-support-owner(at)postgresql(dot)org per conto di Jason L. Buberel
Inviato: mer 04/04/2007 6.48
A: pgadmin-support(at)postgresql(dot)org
Oggetto: [pgadmin-support] Builds errors with 1.6.3 and wxWidgets 2.8.1 on Ubuntu
 
Similarly to what was reported here with v1.6.2:
http://www.pgadmin.org/archives/pgadmin-support/2007-01/msg00065.php

I am trying to compile v1.6.3 from sources on Ubuntu Feisty Fawn (the 
current beta). This comes with wxWidgets 2.8.1.1, which I have installed:

ii  wx2.8-doc                 2.8.1.1-0ubuntu4          wxWidgets 
Cross-platform C++ GUI toolkit (documentation)
ii  wx2.8-examples            2.8.1.1-0ubuntu4          wxWidgets 
Cross-platform C++ GUI toolkit (examples)
ii  wx2.8-headers             2.8.1.1-0ubuntu4          wxWidgets 
Cross-platform C++ GUI toolkit (header files)
ii  wx2.8-i18n                2.8.1.1-0ubuntu4          wxWidgets 
Cross-platform C++ GUI toolkit (i18n support)

The configure works just fine, but towards the end I get the following 
compilation error on a very clean build:

g++ -DDATA_DIR=\"/opt/pgadmin-1.6/share/pgadmin3/\" -Wall 
-Wno-non-virtual-dtor -I./include   -L/opt/postgres-8.1.4//lib 
-L/usr/lib -o pgagent  connection.o job.o misc.o pgAgent.o unix.o 
-pthread   -lwx_baseu-2.8  -L/opt/postgres-8.1.4/lib -lcrypto -lpq
connection.o: In function `wxTransform2D::Transform(wxRect2DInt*) const':
connection.cpp:(.text._ZNK13wxTransform2D9TransformEP11wxRect2DInt[wxTransform2D::Transform(wxRect2DInt*) 
const]+0x96): undefined reference to `wxRect2DInt::operator=(wxRect2DInt 
const&)'
connection.o: In function `wxTransform2D::InverseTransform(wxRect2DInt*) 
const':
connection.cpp:(.text._ZNK13wxTransform2D16InverseTransformEP11wxRect2DInt[wxTransform2D::InverseTransform(wxRect2DInt*) 
const]+0x96): undefined reference to `wxRect2DInt::operator=(wxRect2DInt 
const&)'
collect2: ld returned 1 exit status

Is this indeed the same issue as reported previously, still existing in 
v1.6.3?

Thanks,
Jason








---------------------------(end of broadcast)---------------------------
TIP 7: You can help support the PostgreSQL project by donating at

                http://www.postgresql.org/about/donate



Attachment: acinclude.m4.diff
Description: text/plain (1.1 KB)

In response to

Responses

pgadmin-support by date

Next:From: Dave PageDate: 2007-05-10 12:55:42
Subject: Re: R: Builds errors with 1.6.3 and wxWidgets 2.8.1 on Ubuntu
Previous:From: Leszek TrenknerDate: 2007-05-09 22:14:59
Subject: Re: Pgadmin does not execute backup on table on tablespace

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group