Skip site navigation (1) Skip section navigation (2)

Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment

From: James William Pye <lists(at)jwp(dot)name>
To: Josh Berkus <josh(at)agliodbs(dot)com>
Cc: pgsql-testers(at)postgresql(dot)org, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Lou Picciano <loupicciano(at)comcast(dot)net>
Subject: Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Date: 2010-09-13 02:51:24
Message-ID: 97F0B24B-FD8D-4277-8E96-9680C66EF1D5@jwp.name (view raw or flat)
Thread:
Lists: pgsql-testers
On Sep 12, 2010, at 3:23 PM, Josh Berkus wrote:
> Hmmm.  Tom Lane says "pilot error" because there are two versions of
> Python in the path.  Specifically:

ugh, :(

Yeah, that's correct:

--with-python \
--with-includes=/usr/local/include/python3.1:/usr/local/include:/usr/local/ssl/include 
--with-libraries=/usr/local/lib/python3.1:/usr/local/lib:/usr/local/ssl/lib


I was drawing from some trickiness I experienced getting my plpy vs plpython test rig going.
I think it kept favoring python2 when I wanted python3 as both were in $PATH.

IIRC, what he needs to do is remove the python2 bin-directory from the PATH in order to get 3.x selected by configure. Seems less than user friendly...

In response to

Responses

pgsql-testers by date

Next:From: Tom LaneDate: 2010-09-13 03:19:48
Subject: Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Previous:From: Lou PiccianoDate: 2010-09-13 02:10:46
Subject: pg_upgrade 9b4 -> 9rc1 odd behavior with -u (non-)postgres

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group