Skip site navigation (1) Skip section navigation (2)

Re: BUG #4056: problem creating function with domain argument

From: "Dave Page" <dpage(at)pgadmin(dot)org>
To: "Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: "eric melbardis" <eric(dot)melbardis(at)netkitsolutions(dot)com>, pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #4056: problem creating function with domain argument
Date: 2008-03-27 15:52:03
Message-ID: (view raw or whole thread)
Lists: pgsql-bugs
On Tue, Mar 25, 2008 at 5:37 AM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
> "eric melbardis" <eric(dot)melbardis(at)netkitsolutions(dot)com> writes:
>  > Description:        problem creating function with domain argument
>  AFAICT this example works fine in psql.  You need to take it up
>  on the pgAdmin mailing list.  It looks to me like pgAdmin is mistakenly
>  thinking that a domain has type modifiers.

pgAdmin is using format_type() with a query like:

postgres=# SELECT oid, format_type(oid, typtypmod) AS typname FROM
pg_type where oid = 'dt_0'::regtype;
  oid  | typname
 35130 | dt_0(36)
(1 row)

I would expect it to format the type appropriately.

Dave Page
EnterpriseDB UK Ltd:
PostgreSQL UK 2008 Conference:

In response to


pgsql-bugs by date

Next:From: Alvaro HerreraDate: 2008-03-27 16:07:43
Subject: Re: Extra empty lines PGv8.3.1
Previous:From: Eugen.KonkovDate: 2008-03-27 15:51:58
Subject: Extra empty lines PGv8.3.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group