Skip site navigation (1) Skip section navigation (2)

Re: BUG #3964: Parsing error in Stack Builder with LATIN1 client encoding

From: "Dave Page" <dpage(at)pgadmin(dot)org>
To: Jan-Peter(dot)Seifert(at)gmx(dot)de, pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #3964: Parsing error in Stack Builder with LATIN1 client encoding
Date: 2008-02-19 12:54:28
Message-ID: 937d27e10802190454p42bbbddx28265db868460b8@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-bugs
On Feb 18, 2008 4:53 PM,  <Jan-Peter(dot)Seifert(at)gmx(dot)de> wrote:
> Hi there,
>
> > Betreff: Re: [BUGS] BUG #3964: Parsing error in Stack Builder with LATIN1 client encoding
>
>
> > On Fri, Feb 15, 2008 at 9:41 AM, Jan-Peter Seifert
> > <Jan-Peter(dot)Seifert(at)gmx(dot)de> wrote:
> > >
> > >  The following bug has been logged online:
> > >
> > >  Bug reference:      3964
> > >  Logged by:          Jan-Peter Seifert
> > >  Email address:      Jan-Peter(dot)Seifert(at)gmx(dot)de
> > >  PostgreSQL version: 8.3.0
> > >  Operating system:   Windows xp sp2 German
> > >  Description:        Parsing error in Stack Builder with LATIN1 client
> > >  encoding
> > >  Details:
> > >
> > >  When choosing LATIN1 instead of the default CP1252 for the client
> > encoding I
> > >  get this error in PostgreSQL & EnterpriseDB Stack Builder:
> > >
> > >  13:42:54: Fehler beim Lesen des XML: 'syntax error' in Zeile 1
> > >  13:42:54: Konnte die Anwendungsliste nicht parsen:
> > >  http://www.postgresql.org/applications.xml
> > >
> > >  It doesn't matter whether the server encoding is LATIN1 or not.
> >
> > What exactly are you doing? Stackbuilder never talks to the database
> > server, and has no encoding options at all.
>
> Well, if I choose LATIN1 as the encoding for the client in the setup / cluster initialization the parser in the Stack Builder exits with the error mentioned above. If I choose the default WIN1252 the Stack Builder works correctly. I did make installs on copies of a German Windows xp sp2 VMWare image. However, now it seems to be working after it has once been installed correctly. Strange.

I honestly don't see how the client encoding option could affect
StackBuilder - all it does is change the command line options that are
written to the start menu shortcut for psql, and sets PGCLIENTENCODING
for the command prompt shortcut. StackBuilder itself doesn't know
anything about PostgreSQL at all - it's an entirely standalone
application!!

FWIW, I tested this anyway, and it works fine here (except that the
server complains that conversion between win1252 and latin1 isn't
supported when I try to run psql).

-- 
Dave Page
EnterpriseDB UK: http://www.enterprisedb.com
The Oracle-compatible database company

In response to

pgsql-bugs by date

Next:From: Ricardo DavidDate: 2008-02-19 13:10:57
Subject: BUG #3970: ODBC Unknown Sizes Bug?
Previous:From: ITAGAKI TakahiroDate: 2008-02-19 12:16:14
Subject: BUG #3969: pg_ctl cannot detect server startup

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group