Skip site navigation (1) Skip section navigation (2)

Re: Can't get the debugger going

From: "Dave Page" <dpage(at)postgresql(dot)org>
To: rod(at)iol(dot)ie
Cc: Pgadmin-Support <pgadmin-support(at)postgresql(dot)org>
Subject: Re: Can't get the debugger going
Date: 2008-02-04 16:38:05
Message-ID: 937d27e10802040838x59384e34gee511121cd5b755c@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
On Feb 4, 2008 4:13 PM, Raymond O'Donnell <rod(at)iol(dot)ie> wrote:
> Hi all,
>
> As the subject line says..... I've downloaded PG 8.3 (Win32) and
> included the pl/pgsql debugger in the installation options; I've also
> upgraded PgAdmin to 1.8.2. I checked that the debugger files were there,
> and they are - C:\Program Files\PostgreSQL\8.3\lib\plugins contains
> plugin_debugger.dll and plugin_profiler.dll; and I even added this
> folder to the PATH.
>
> However, Tools -> Debugging remains greyed out, and the "Debug" items
> which the help says ought to appear on the contect menu for functions
> isn't there.
>
> What am I missing?

Are you trying to debug a function that isn't written in pl/pgsql?
Also, make sure the debugger functions are loaded in the database you
wish to debug - if you've restored a dump into a database created form
template0, they might not be (there should be an sql script in the
server's share directory).

/D

In response to

Responses

pgadmin-support by date

Next:From: Raymond O'DonnellDate: 2008-02-04 17:33:09
Subject: Re: Can't get the debugger going
Previous:From: Raymond O'DonnellDate: 2008-02-04 16:13:09
Subject: Can't get the debugger going

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group