Skip site navigation (1) Skip section navigation (2)

Re: WARNING: uuid.h: present but cannot be compiled

From: "David E(dot) Wheeler" <david(at)justatheory(dot)com>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: WARNING: uuid.h: present but cannot be compiled
Date: 2009-04-17 16:13:52
Message-ID: 805BB76C-2A4A-41AD-B170-3C32909CD992@justatheory.com (view raw or flat)
Thread:
Lists: pgsql-bugs
On Apr 17, 2009, at 7:08 AM, Tom Lane wrote:

> "David E. Wheeler" <david(at)justatheory(dot)com> writes:
>> I'm building 8.4beta1 on Mac OS X 10.5.6. I have ossp-uuid installed
>> with its includes in /usr/local/include/ossp-uuid.
>
> Well, then you would need --with-includes=/usr/local/include/ossp-uuid
> (don't bother setting CPPFLAGS in addition).

Duh, I already had --with-includes for another directory. Thanks.

>> I guess it's finding Apple's uuid.h and not OSSP's?
>
> Yeah, that's what it looks like, although it's odd that that fails
> to compile.

Yeah, seems odd…

Best,

David


In response to

Responses

pgsql-bugs by date

Next:From: David E. WheelerDate: 2009-04-17 17:47:47
Subject: Re: WARNING: uuid.h: present but cannot be compiled
Previous:From: Tom LaneDate: 2009-04-17 14:08:53
Subject: Re: WARNING: uuid.h: present but cannot be compiled

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group