Skip site navigation (1) Skip section navigation (2)

DBD::Pg 2.10.7 compile failed on RH4

From: <Tapio(dot)Niva(at)tietoenator(dot)com>
To: <pgsql-interfaces(at)postgresql(dot)org>
Subject: DBD::Pg 2.10.7 compile failed on RH4
Date: 2008-10-07 07:25:38
Message-ID: 74C0611212AC994FA92E965255B0FDFE0B33B1@lotus.eu.tieto.com (view raw or flat)
Thread:
Lists: pgsql-interfaces
Hello,
we have 32-bit PostgreSQL version 8.3.4 on 64-bit RHEL4 , Postgres
itself is working as expected. 
We are using PostreSQL via following perl version
............................................
# perl -v
This is perl, v5.10.0 built for i686-linux-thread-multi
(with 4 registered patches, see perl -V for more detail)
Copyright 1987-2007, Larry Wall
Binary build 1004 [287188] provided by ActiveState
http://www.ActiveState.com
Built Sep  3 2008 11:22:08
............................................

Our problem is that DBD::Pg version 2.10.7 will not compile ,
/usr/bin/ld skips all libpq files as incompatible - please see a slice
of the result below :
............................................
rm -f blib/arch/auto/DBD/Pg/Pg.so
LD_RUN_PATH="/usr/lib" gcc  -shared -O2 Pg.o dbdimp.o quote.o types.o
-o blib/arch/auto/DBD/Pg/Pg.so   \
   -L/usr/lib -lpq -lm          \
  
/usr/bin/ld: skipping incompatible /usr/lib/libpq.so when searching for
-lpq
/usr/bin/ld: skipping incompatible /usr/lib/libpq.a when searching for
-lpq
/usr/bin/ld: skipping incompatible
/usr/lib/gcc/x86_64-redhat-linux/3.4.6/../../../libpq.so when searching
for -lpq
/usr/bin/ld: skipping incompatible
/usr/lib/gcc/x86_64-redhat-linux/3.4.6/../../../libpq.a when searching
for -lpq
/usr/bin/ld: skipping incompatible /usr/lib/libpq.so when searching for
-lpq
/usr/bin/ld: skipping incompatible /usr/lib/libpq.a when searching for
-lpq
/usr/bin/ld: cannot find -lpq
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/DBD/Pg/Pg.so] Error 1
............................................
libpq files available are as below :

# ll /usr/lib/libpq.so
lrwxrwxrwx  1 root root 12 Oct  6 14:06 /usr/lib/libpq.so ->
libpq.so.5.1
# ll /usr/lib/libpq.so.5.1
-rwxr-xr-x  1 root root 122616 Sep 20 18:52 /usr/lib/libpq.so.5.1
# file /usr/lib/libpq.so.5.1
/usr/lib/libpq.so.5.1: ELF 32-bit LSB shared object, Intel 80386,
version 1 (SYSV), stripped

Any ideas how to proceed ?

Best Regards,
  Tapio


pgsql-interfaces by date

Next:From: Jakob LechnerDate: 2008-10-13 07:53:01
Subject: Timestamp with libpq
Previous:From: Francisco Figueiredo Jr.Date: 2008-10-06 05:18:27
Subject: Npgsql2 Final Released!!

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group