Skip site navigation (1) Skip section navigation (2)

Re: BUG #1095: make can't find plperl

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: siderite(at)go(dot)ro
Cc: "PostgreSQL Bugs List" <pgsql-bugs(at)postgresql(dot)org>
Subject: Re: BUG #1095: make can't find plperl
Date: 2004-03-10 16:06:56
Message-ID: 7118.1078934816@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-bugs
"PostgreSQL Bugs List" <pgsql-bugs(at)postgresql(dot)org> writes:
>   I am trying to configure PostgreSQL 7.4.2 with Perl 5.8.3 or 5.9.0. I 
> compiled both versions of Perl, with shared libraries and with no shared 
> libraries. Then I 'configure'd postgres with '--with-perl' with no error. 
>   Every time I run 'make', though, I get an error that it does not find 
> /pl/plperl. The problem is described by only one person I could find at url: 
> http://archives.postgresql.org/pgsql-bugs/2003-09/msg00184.php.

I think this is likely to be the result if you download only the "base"
tarfile and then try to configure options that aren't in the base.

It might be a good idea to improve the configure script to complain if
the optional sources aren't present and you request building them.

			regards, tom lane

In response to

pgsql-bugs by date

Next:From: Josh BerkusDate: 2004-03-10 20:43:40
Subject: Glitch: cannot use Arrays with Raise Notice
Previous:From: Richard HuxtonDate: 2004-03-10 11:20:39
Subject: Re: not necessarily a bug...

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group