Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us> writes:
> It was done quickly to complete it for beta2. Neil talked to Tom and me
> about it before he made the change. Obviously we all guessed wrong on
> this one.
Personally I had forgotten that pg_cancel_backend was in the previous
release and so there was a backwards-compatibility issue to consider.
There's no doubt that a boolean return value is cleaner than an int
return value, but we don't ordinarily make non-backward-compatible
changes just because they're cleaner. Comparable case: timeofday()
is still returning text not timestamptz after all these years, even
though that is *obviously* the wrong API, and even though we could
probably change it without a huge risk of breaking things.
As for the total-vs-complete function name business, I do personally
like "total" better, but the time to have been making that argument was
back during the original discussion, which itself went on way too long.
Renaming it now with relatively little discussion was definitely a
violation of our normal development process. I'll take my fair share
of the blame for this, because I encouraged Neil to do it without
stopping to think that the names had already been hashed over
extensively. But it was the wrong way to proceed.
In short, yeah, I think we should revert.
regards, tom lane
In response to
pgsql-hackers by date
|Next:||From: Bruce Momjian||Date: 2005-09-29 02:23:01|
|Subject: Re: [PATCHES] Proposed patch for sequence-renaming problems|
|Previous:||From: Bruce Momjian||Date: 2005-09-29 02:21:00|
|Subject: Re: Found small issue with OUT params|