Skip site navigation (1) Skip section navigation (2)

Re: [Problem] - Error: cannot open pg_class_oid_index: Permission denied

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: "Selvakaruppiah s-TLS,Chennai" <Selvakaruppiahs(at)hcl(dot)in>
Cc: pgsql-novice(at)postgresql(dot)org
Subject: Re: [Problem] - Error: cannot open pg_class_oid_index: Permission denied
Date: 2008-07-09 06:54:13
Message-ID: 6000.1215586453@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-novice
"Selvakaruppiah s-TLS,Chennai" <Selvakaruppiahs(at)hcl(dot)in> writes:
> Actually my application is using the postgres 7.2.4 as backend.

[ blink... ]  Please tell us that is a typo.  7.2.4 is more than five
years old, and the entire 7.2 branch was abandoned as unfixably buggy
and insecure more than three years ago.  If you're using a software
distribution that presents 7.2.4 as a current version, then you have
equally bad problems for every other part of that distribution.

> Mac 1: At 6:51:15 - ERROR:  cannot open pg_class_oid_index: Permission denied

The only cause I've heard of for sudden occurrences of "permission
denied" errors on databases that had been working is interference
of broken Windows antivirus software.  If you're running 7.2 atop
Cygwin atop Windows (which is the only way 7.2 could have run on
Windows) then you really are working with a house of cards --- get
yourself to a native PG install using recent 8.2.x or 8.3.x.  Your
AV software will still be just as broken though, so you likely
also need to update or remove it.  (Dare I suggest installing a
real operating system instead of M$?)

			regards, tom lane

In response to

pgsql-novice by date

Next:From: Emil ObermayrDate: 2008-07-09 07:12:50
Subject: Re: how to get dependancies of a table?
Previous:From: Selvakaruppiah s-TLS,ChennaiDate: 2008-07-09 06:08:47
Subject: [Problem] - Error: cannot open pg_class_oid_index: Permission denied

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group