Skip site navigation (1) Skip section navigation (2)

Re: Can't compile pgadmin3-1.10.1

From: Haiyan Chi <gccchy(at)gmail(dot)com>
To: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: Can't compile pgadmin3-1.10.1
Date: 2010-02-19 20:14:32
Message-ID: 507531fe1002191214y415227f1ydc6d8ea324ef0b12@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
Thank you so much, Guillaume. After compile the wxWidgets contribs,
pgadmin3-1.10.1 has been installed.
But when I tried to run ./pgadmin3, I got the following error:
***********
./pgadmin3: relocation error: ./pgadmin3: symbol
_ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvmS2_, version
WXU_2.8.5 not defined in file libwx_baseu-2.8.so.0 with link time reference
***********
Did I missed something? Thanks advance for your help.

Haiyan

On Fri, Feb 19, 2010 at 2:40 PM, Guillaume Lelarge
<guillaume(at)lelarge(dot)info>wrote:

> Hi,
>
> Le 19/02/2010 20:35, Haiyan Chi a écrit :
> > [...]
> > I am installing  pgadmin3-1.10.1 from source.  I am at linux.
> >
> > The configuration passed:
> >
> >
> > *************************
> > PostgreSQL directory:
> > /cis/local/biocard_xnat/xnat/postgres
> > PostgreSQL pg_config binary:
> > /cis/local/biocard_xnat/xnat/postgres/bin/pg_config
> > PostgreSQL version:                     PostgreSQL
> > 8.4.2
> > PostgreSQL SSL support:
> > Present
> >
> > wxWidgets directory:
> > /cis/local/biocard_xnat/xnat/opt/wxgtk
> > wxWidgets wx-config binary:
> > /cis/local/biocard_xnat/xnat/opt/wxgtk/bin/wx-config
> > wxWidgets version:                      wxWidgets
> > 2.8.10
> >
> > libxml2 directory:
> > /cis/local/biocard_xnat/xnat/opt/xmlinst
> > libxml2 xml2-config binary:
> > /cis/local/biocard_xnat/xnat/opt/xmlinst/bin/xml2-config
> > libxml2 version:                        libxml2
> > 2.7.6
> >
> > libxslt directory:
> > /cis/local/biocard_xnat/xnat/opt/xslt
> > libxslt xslt-config binary:
> > /cis/local/biocard_xnat/xnat/opt/xslt/bin/xslt-config
> > libxslt version:                        libxslt 1.1.21
> >
> > Building a debug version of pgAdmin:    No
> > Statically linking pgAdmin:             No
> > Building a Mac OS X appbundle:          No
> >
> > pgAdmin configuration is now complete. You can now compile and
> > install pgAdmin using 'make; make install'.
> > *******************************
> >
> >
> > When I tried to compile, got the following error:
> > [...]
>
> You probably forgot to compile the wxWidgets contribs. Go in the contrib
> directory and "make && make install".
>
>
> --
> Guillaume.
>  http://www.postgresqlfr.org
>  http://dalibo.com
>



-- 
7732 Heatherside Ln,
Ellicott City, MD 21043
Cell:    301-367-9541
Home: 410-796-7180

In response to

Responses

pgadmin-hackers by date

Next:From: Guillaume LelargeDate: 2010-02-19 20:19:37
Subject: Re: Can't compile pgadmin3-1.10.1
Previous:From: Guillaume LelargeDate: 2010-02-19 19:40:30
Subject: Re: Can't compile pgadmin3-1.10.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group