Skip site navigation (1) Skip section navigation (2)

Usuario postgres no puede conectarse a la BD después de actualización

From: "Jose R(dot) Prieto Pazos" <joser(dot)prieto(at)gmail(dot)com>
To: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Usuario postgres no puede conectarse a la BD después de actualización
Date: 2011-12-07 20:32:45
Message-ID: 4EDFCD6D.4070607@gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Hola:

Creo que ha sido tras una actualización de Ubuntu, que no puedo conectar
a PostgreSQL con el usuario postgres, ni con pgAdmin, ni con phpP gAdmin

Ficheros de configuración:

pg_hba.conf:

# Database administrative login by UNIX sockets
local   all         postgres                          ident
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
local   all         all                               md5
# IPv4 local connections:
host    all         all         127.0.0.1/32          md5
# IPv6 local connections:
host    all         all         ::1/128               md5

Log de arranque del servidor:

2011-12-07 20:12:09 CET LOG:  el sistema de bases de datos est? apagado
2011-12-07 20:12:11 CET LOG:  el sistema de bases de datos fue apagado
en 2011-12-07 20:12:09 CET
2011-12-07 20:12:11 CET LOG:  el sistema de bases de datos est? listo
para aceptar conexiones
2011-12-07 20:12:11 CET LOG:  conexi?n recibida: host=[local]
2011-12-07 20:12:11 CET LOG:  el paquete de inicio est? incompleto
2011-12-07 20:12:12 CET LOG:  conexi?n recibida: host=[local]
2011-12-07 20:12:12 CET LOG:  conexi?n autorizada: usuario=postgres
database=postgres
2011-12-07 20:12:12 CET LOG:  conexi?n recibida: host=[local]
2011-12-07 20:12:12 CET LOG:  conexi?n autorizada: usuario=postgres
database=postgres
2011-12-07 20:12:13 CET LOG:  conexi?n recibida: host=[local]
2011-12-07 20:12:13 CET LOG:  conexi?n autorizada: usuario=postgres
database=postgres
2011-12-07 21:06:43 CET LOG:  conexi?n recibida: host=[local]
2011-12-07 21:06:43 CET LOG:  el paquete de inicio est? incompleto

Sin embargo, si utilizo otro usuario (el usuario que tengo para OpenERP,
en concreto), me conecta desde phpPgAdmin, y desde el propio OpenERP,
pero NO desde pgAdmin:

2011-12-07 21:11:30 CET LOG:  conexi?n recibida: host=::1 port=53830
2011-12-07 21:11:30 CET LOG:  conexi?n autorizada: usuario=XXXXXXXXXX
database=template1
2011-12-07 21:11:35 CET LOG:  conexi?n recibida: host=::1 port=53835
2011-12-07 21:11:35 CET LOG:  conexi?n autorizada: usuario=XXXXXXXXXX
database=NNNNNNNNNNN

Esto es tras conectarme con OpenERP; desde phpPgAdmin:
2011-12-07 21:14:28 CET LOG:  conexi?n recibida: host=::1 port=53904
2011-12-07 21:14:28 CET LOG:  conexi?n autorizada: usuario=XXXXXXXXXX
database=template1
2011-12-07 21:14:28 CET LOG:  conexi?n recibida: host=::1 port=53907
2011-12-07 21:14:28 CET LOG:  conexi?n autorizada: usuario=XXXXXXXXXX
database=template1

Con otro usuario diferente, también pasa lo mismo, desde phpPgAdmin.
Pero el usuario postgres no puede acceder :S

Supongo que pasó tras la actualización vía apt-get, aunque no puedo
asegurarlo.
OpenERP no se ejecuta como demonio, sino que lo levanto bajo demanda.
Bajo Ubuntu 10.04.3

# lsb_release -a
LSB Version:   
core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID:    Ubuntu
Description:    Ubuntu 10.04.3 LTS
Release:    10.04
Codename:    lucid

PostgreSQL 8.4, paquete oficial de Ubuntu, 8.4.9-0ubuntu0.10.04 (y no
veo encuentro ningún bug similar en Launchpad :S )

pgsql-es-ayuda by date

Next:From: Marco Vinicio Jimenez RojasDate: 2011-12-07 21:20:16
Subject: error en funcion
Previous:From: anthonyDate: 2011-12-07 19:29:54
Subject: Re: lenguaje no encontrado en funcion

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group