Skip site navigation (1) Skip section navigation (2)

Re: Problem with standby

From: Josh Berkus <josh(at)agliodbs(dot)com>
To: pgsql-testers(at)postgresql(dot)org
Subject: Re: Problem with standby
Date: 2010-09-08 17:14:09
Message-ID: 4C87C461.2010108@agliodbs.com (view raw or flat)
Thread:
Lists: pgsql-testers
On 09/08/2010 05:28 AM, Jai Soni wrote:
>
> Dear pgsql-testers
>
> i have installed postgresql 9.0 beta1 and testing its streaming
> replication feature
> when i set up the replication env (i.e. primary and standby servers)
> everything was fine and the replication goes successful but last
> three-four days the standby server does not doing replication i have
> appended the log messages that i received in standby server

There have been a lot of fixes to Standby since Beta1.  Please do try a 
more recent version, like RC1.

The message you are getting indicates that for some reason the standby 
stopped replicating for a long enough period for the transaction records 
to be deleted on the Master.  If you are not using WAL archiving as a 
backup for falling behind, then your only choice is to re-clone the standby.

-- 
                                   -- Josh Berkus
                                      PostgreSQL Experts Inc.
                                      http://www.pgexperts.com

In response to

pgsql-testers by date

Next:From: Adam RauchDate: 2010-09-10 20:32:09
Subject: [TEST REPORT] StackBuilder installs old JDBC driver (in strange location on 64-bit Windows)
Previous:From: Jai SoniDate: 2010-09-08 12:28:42
Subject: Problem with standby

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group