Skip site navigation (1) Skip section navigation (2)

Re: Instalación postgresql-8.1 en Ubuntu 9.10

From: "Alberto Rivera M(dot)" <rivera(dot)alberto(at)gmail(dot)com>
To: Alvaro Herrera <alvherre(at)alvh(dot)no-ip(dot)org>
Cc: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: Instalación postgresql-8.1 en Ubuntu 9.10
Date: 2010-02-08 21:00:53
Message-ID: 4B707B85.8060108@gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Alvaro Herrera wrote:
> Alberto Rivera M. escribió:
>
>   
>> A todo esto que opinas de tener la 8.1 en un servidor de producción
>> ??? yo había subido la versión a la 8.3 y ahora iba a subirla a la
>> 8.4
>>     
>
> 8.1 sigue siendo una versión soportada.  Si te funciona dentro de las
> limitaciones que tiene, no veo problema.
>
>   
>> pero existen unos módulos de un sistema que sencillamente no
>> reconocen las 8.3 anda a saber tu porqué... pero ya la pillaré ....
>>     
>
> Probablemente tienes que recompilar para tener el nuevo PG_MODULE_MAGIC
> (no puedes llegar y poner un módulo en $libdir de una versión anterior;
> es necesario recompilarlo).
>
>   
La verdad es que lo actualicé por algunos problemas de seguridad que 
había sido corregidos con la versión 8.3, la versión que tengo 
actualmente en uno de los servidores y que es puntualmente la que está 
corriendo y soportando algunos de los scripts es la 8.1.13 ... que 
opinas??? sorry por consultarte tanto pero dentro de mis conocidos eres 
el que más sabe de postgres yo soy sólo un novato más en el tema ...

Ahora con respecto a la instalación en el equipo local en Ubuntu 9.10 no 
me pescó así que lo estoy compilando nuevamente ;) pero me aparece este 
error en el make :

make[3]: *** [libplperl.so.0.0] Error 1
make[3]: se sale del directorio `/opt/postgresql-8.1.18/src/pl/plperl'
make[2]: *** [all] Error 1
make[2]: se sale del directorio `/opt/postgresql-8.1.18/src/pl'
make[1]: *** [all] Error 2
make[1]: se sale del directorio `/opt/postgresql-8.1.18/src'
make: *** [all] Error 2

:) gracias Alvaro por tu ayuda


In response to

Responses

pgsql-es-ayuda by date

Next:From: Jaime ArrietaDate: 2010-02-08 21:01:31
Subject: Consulta sobre servidor remoto
Previous:From: Alvaro HerreraDate: 2010-02-08 20:44:28
Subject: Re: Vacuum: pg_statistic_relid_att_index, duplicate key violates

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group