Skip site navigation (1) Skip section navigation (2)

Re: plperl compiler warning

From: Joe Conway <mail(at)joeconway(dot)com>
To: Tim Bunce <Tim(dot)Bunce(at)pobox(dot)com>
Cc: "Hackers (PostgreSQL)" <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: plperl compiler warning
Date: 2010-01-28 16:27:04
Message-ID: 4B61BAD8.7000903@joeconway.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On 01/28/2010 07:30 AM, Tim Bunce wrote:
> On Thu, Jan 28, 2010 at 06:31:19AM -0800, Joe Conway wrote:
>> Last night I noted the following warning:
>>
>> plperl.c: In function ‘plperl_create_sub’:
>>
>> plperl.c:1117: warning: null argument where non-null required (argument 2)
> 
> The master branch of my git clone says line 1117 is:
> 
>     subref = newRV_inc((SV*)GvCVu((GV*)sub_glob));
> 
> Does that match yours? (If not, what is the text on the line?)

I pull directly from CVS, not git, but in any case my line 1117 is

      subref = newRV_inc((SV*)GvCVu((GV*)sub_glob));

so it appears to be the same

> What perl version are you using?
> What compiler version are you using?

I'm on stock Fedora 12:

perl.x86_64             4:5.10.0-87.fc12
gcc.x86_64              4.4.2-20.fc12

HTH,

Joe

In response to

Responses

pgsql-hackers by date

Next:From: Tim BunceDate: 2010-01-28 16:32:30
Subject: Re: Add on_trusted_init and on_untrusted_init to plperl [PATCH]
Previous:From: Simon RiggsDate: 2010-01-28 16:22:10
Subject: Re: Streaming replication, and walsender during recovery

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group