Skip site navigation (1) Skip section navigation (2)

Re: can't stop autovacuum by HUP'ing the server

From: "Dave Cramer" <pg(at)fastcrypt(dot)com>
To: "Alvaro Herrera" <alvherre(at)commandprompt(dot)com>
Cc: "Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: can't stop autovacuum by HUP'ing the server
Date: 2008-08-26 16:18:22
Message-ID: 491f66a50808260918p4b34a6dfve1cfa408b24cc8f0@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Tue, Aug 26, 2008 at 12:10 PM, Alvaro Herrera <alvherre(at)commandprompt(dot)com
> wrote:

> Dave Cramer wrote:
>
>
> > AutoVacuumShmem->av_signal[AutoVacForkFailed] = false;
> >                                 pg_usleep(100000L);             /* 100ms
> */
> >
> > SendPostmasterSignal(PMSIGNAL_START_AUTOVAC_WORKER);
> >                                 continue;
> >
> > Do these signals get cleaned up on a reload ?
>
> Well, not on a reload specifically, but this signal is of prompt
> response (i.e. the postmaster acts immediately on it).  See
> CheckPostmasterSignal.  Also, note that this code starts a worker, not
> the launcher which is what you're seeing.
>
>
Ok, back to why

turns out template0 is the culprit, why is autovac not vacuuming this ?

Dave

In response to

Responses

pgsql-hackers by date

Next:From: Alvaro HerreraDate: 2008-08-26 16:21:30
Subject: Re: can't stop autovacuum by HUP'ing the server
Previous:From: Alvaro HerreraDate: 2008-08-26 16:10:56
Subject: Re: can't stop autovacuum by HUP'ing the server

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group