Skip site navigation (1) Skip section navigation (2)

Re: postmaster blues after system restart

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: "Thomas F(dot) O'Connell" <tfo(at)sitening(dot)com>
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: postmaster blues after system restart
Date: 2005-10-14 02:35:47
Message-ID: 4889.1129257347@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-admin
"Thomas F. O'Connell" <tfo(at)sitening(dot)com> writes:
> When I restart, everything seems to come up fine with the exception  
> that postmaster starts in a state such that it doesn't seem to be  
> accepting connections (either over UNIX or TCP/IP). As best I can  
> tell, it is using the init script to start postgres because  
> pg_autovacuum tries to start, too, and dies shortly after the box  
> comes up because it, too, cannot connect to postgres.

hmmm ... maybe you need to start your DNS server first?

> Also, is there any way to get more status out of a postmaster if one  
> cannot connect to it?

One thing I'd look into is exactly what ports it's listening to ---
try lsof and/or netstat for this.  Also, have you looked at the
postmaster log?

			regards, tom lane

In response to

Responses

pgsql-admin by date

Next:From: Thomas F. O'ConnellDate: 2005-10-14 02:40:59
Subject: Re: postmaster blues after system restart
Previous:From: Jeff FrostDate: 2005-10-14 01:38:11
Subject: Re: postmaster blues after system restart

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group