Skip site navigation (1) Skip section navigation (2)

Re: Can't login to 8.2.4 if not superuser...

From: Daniel Rubio <drubior(at)tinet(dot)org>
To: pgsql-admin(at)postgresql(dot)org
Subject: Re: Can't login to 8.2.4 if not superuser...
Date: 2007-09-07 07:05:49
Message-ID: 46E0F84D.4080409@tinet.org (view raw or flat)
Thread:
Lists: pgsql-admin
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Our new Server is a sun T2000 with the "CoolThreads" technology.<br>
Wi installed the recomended gcc version to take advantage of the new
features of this technology:<br>
<br>
Using built-in specs.<br>
Target: sparc-sun-solaris2.10<br>
Configured with:
/net/clpt-v490-1/export/data/bldmstr/20070425_mars_gcc/src/configure
--prefix=/usr/sfw --enable&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
-shared --with-system-zlib --enable-checking=release
--disable-libmudflap --enable-languages=c,c++
--enable-vers&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
ion-specific-runtime-libs --with-cpu=v9 --with-ld=/usr/ccs/bin/ld
--without-gnu-ld<br>
Thread model: posix<br>
gcc version 4.0.4 (gccfss)<br>
<br>
Here is the pg_config output:<br>
<br>
BINDIR = /usr/bin<br>
DOCDIR = /usr/share/doc/pgsql/8.1.4<br>
INCLUDEDIR = /usr/include/pgsql<br>
PKGINCLUDEDIR = /usr/include/pgsql<br>
INCLUDEDIR-SERVER = /usr/include/pgsql/server<br>
LIBDIR = /usr/lib<br>
PKGLIBDIR = /usr/lib<br>
LOCALEDIR = /usr/share/locale<br>
MANDIR = /usr/share/man<br>
SHAREDIR = /usr/share/pgsql<br>
SYSCONFDIR = /etc/pgsql<br>
PGXS = /usr/lib/pgxs/src/makefiles/pgxs.mk<br>
CONFIGURE = '--prefix=/usr' '--bindir=/usr/bin' '--libexecdir=/usr/bin'
'--sbindir=/usr/bin' '--datadir=/usr/share/pgsql'
'--sysconfdir=/etc/pgsql' '--mandir=/usr/share/man' '--libdir=/usr/lib'
'--includedir=/usr/include/pgsql' '--sharedstatedir=/var/lib/pgsql'
'--localstatedir=/var/lib/pgsql' '--enable-nls'
'--with-localedir=/usr/share/locale'
'--with-docdir=/usr/share/doc/pgsql/8.1.4' '--with-tcl' '--with-perl'
'--with-python' '--with-pam' '--with-openssl' '--enable-thread-safety'
'--with-includes=/sfw10/builds/build/sfw10-patch/usr/src/cmd/postgres/rltmp/include:/usr/sfw/include'
'--with-tclconfig=/usr/sfw/lib'
'--with-libs=/sfw10/builds/build/sfw10-patch/usr/src/cmd/postgres/rltmp/lib:/usr/sfw/lib:/usr/lib'
'CC=/ws/on10-tools/SUNWspro/SOS8/bin/cc' 'CFLAGS=-xc99=none -xCC'<br>
CC = /ws/on10-tools/SUNWspro/SOS8/bin/cc<br>
CPPFLAGS =
-I/sfw10/builds/build/sfw10-patch/usr/src/cmd/postgres/rltmp/include
-I/usr/sfw/include<br>
CFLAGS = -xO3 -xarch=v8 -xspace -W0,-Lt -W2,-Rcond_elim -Xa&nbsp; -xildoff&nbsp;
-xc99=none -xCC<br>
CFLAGS_SL = -KPIC<br>
LDFLAGS =
-L/sfw10/builds/build/sfw10-patch/usr/src/cmd/postgres/rltmp/lib
-L/usr/sfw/lib -L/usr/lib -Wl,-R/usr/lib<br>
LDFLAGS_SL =<br>
LIBS = -lpgport -lpam -lssl -lcrypto -lz -lreadline -ltermcap -lrt
-lresolv -lgen -lsocket -lnsl -ldl -lm<br>
VERSION = PostgreSQL 8.1.4<br>
<br>
Now I'm going to recompile using a 3.4.3 version to see what happens...<br>
<br>
<br>
En/na Tom Lane ha escrit:
<blockquote cite="mid:22268(dot)1189088283(at)sss(dot)pgh(dot)pa(dot)us" type="cite">
  <pre wrap="">Daniel Rubio <a class="moz-txt-link-rfc2396E" href="mailto:drubior(at)tinet(dot)org">&lt;drubior(at)tinet(dot)org&gt;</a> writes:
  </pre>
  <blockquote type="cite">
    <pre wrap="">Here's the stack trace, I'm not sure this is all you need (it's the 
first time I use gdb) so, tell me if you need more information
    </pre>
  </blockquote>
  <pre wrap=""><!---->
  </pre>
  <blockquote type="cite">
    <pre wrap="">Core was generated by `/aplicacions/postgres/bin/postmaster -D 
/aplicacions/postgres/data'.
Program terminated with signal 11, Segmentation fault.
#0  0x001a66b4 in HaveNFreeProcs ()
(gdb) backtrace
#0  0x001a66b4 in HaveNFreeProcs ()
#1  0x0024deb4 in InitPostgres ()
#2  0x001b1464 in PostgresMain ()
#3  0x001837f0 in ServerLoop ()
#4  0x00184cd8 in PostmasterMain ()
#5  0x001373f8 in main ()
    </pre>
  </blockquote>
  <pre wrap=""><!---->
Well, that's pretty darn odd.  It looks like you could work around the
crash by setting superuser_reserved_connections to 0, but that doesn't
tell us *why* it's crashing.  HaveNFreeProcs, and the data structure
it looks at, are simple enough that it's hard to credit a bug there.
I'm worried that what you've got is really a compiler bug.  What
compiler did you build with, and did you use any nondefault CFLAGS?
(pg_config output would be helpful here.)

			regards, tom lane



  </pre>
</blockquote>
<br>
<br>
<pre class="moz-signature" cols="72">-- 
********************************************************
Daniel Rubio Rodr&iacute;guez
OASI (Organisme Aut&ograve;nom Per la Societat de la Informaci&oacute;)
c/ Assalt, 12
43003 - Tarragona
Tef.: 977.244.007 - Fax: 977.224.517
e-mail: drubio a oasi.org
******************************************************** </pre>
</body>
</html>



Attachment: unknown_filename
Description: text/html (4.9 KB)

In response to

Responses

pgsql-admin by date

Next:From: Daniel RubioDate: 2007-09-07 07:50:18
Subject: Re: Can't login to 8.2.4 if not superuser...
Previous:From: Richard Broersma JrDate: 2007-09-06 16:08:29
Subject: Re: ADO -PostgreSQL OLE DB Provider

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group