Skip site navigation (1) Skip section navigation (2)

Re: configure --with-wx-version=2.6 should error earlier

From: Dave Page <dpage(at)postgresql(dot)org>
To: Leszek Trenkner <olaf(at)post(dot)pl>
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: configure --with-wx-version=2.6 should error earlier
Date: 2007-06-04 08:57:01
Message-ID: 4663D3DD.9030803@postgresql.org (view raw or flat)
Thread:
Lists: pgadmin-hackers
Leszek Trenkner wrote:
> Dave Page wrote:
> 
>> Kris Jurka wrote:
>>> Running configure --with-wx-version=2.6 succeeds and then bails out
>>> during the build process.  If pgadmin requires 2.8 it should enforce
>>> that at configure time.
>> Agreed - configure check committed to SVN.
>>
> That broke build process (you couldn't even force specific version) on
> Ubuntu Fiesty (and possibly Debian), as one can have more than one
> wx-widgets version installed and default wouldn't be necessary the best
> one. 

Whoops. Sorry. I've committed a fix for this - please test. It helps
that you can do:

wx-config --version --version=2.8

which will return the full version number for the 2.8 installation.

Thanks, Dave.

In response to

pgadmin-hackers by date

Next:From: Dave PageDate: 2007-06-04 10:06:19
Subject: Re: Testing 1.7: issues in edit grid & query window
Previous:From: svnDate: 2007-06-04 08:38:10
Subject: SVN Commit by dpage: r6337 - trunk/pgadmin3

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group