Skip site navigation (1) Skip section navigation (2)

Re: Latest ODBC driver?

From: Mark Morgan Lloyd <markMLl(dot)pgsql-odbc(at)telemetry(dot)co(dot)uk>
To: pgsql-odbc(at)postgresql(dot)org
Subject: Re: Latest ODBC driver?
Date: 2006-08-27 21:48:32
Message-ID: 44F21330.32DDB16@telemetry.co.uk (view raw or flat)
Thread:
Lists: pgsql-odbc
Dave Page wrote:

> > i)   What is the the minimum acceptable ODBC DLL versions I
> > think I saw 3.51 somewhere? Knowing this I might be able to contribute
> > some more coherent testing/debugging info.
> 
> No idea - it's not something that came up before - iirc, the ODBC DM
> hasn't changed much, if at all in the last few versions of MDAC.

Looking back through frenzied research last night when things started going pear
shaped, I find this in the 8.02.0200 release notes:

-----8<-----
4) standardised the build on ODBC version 3.51
----->8-----

Does this correspond to the versions of e.g. odbc32.dll as shown in the control
panel? If so my production machines are way out of date... they're on something
like 3.0 since the NT SPs haven't updated ODBC (can't be sure but I suspect they
might expect IE4 SP2 as a prerequisite).

> > ii)  Does the new driver insist on Unicode, and do I need to
> > accomodate that in the app/database/table setup?
> 
> No, you use what you want and the driver handles it. There were (and
> will continue to be) 2 drivers in 08.02, a Unicode one which most people
> will use, and an ANSI one which is recommended for use with BDE apps,
> and for people having trouble with their combination of LATINx charset
> and whatever they're running on the server (a very small number of
> people).

Noted comment about the BDE- I'm still using that but trying to work to a point
where I can junk it: IMO it's the worst of all worlds. On the other hand once I
get rid of BDE I'm not sure whether I'll continue using ODBC or go direct. Are
there any specific issues I should be watching out for with BDE and the ANSI
driver?

> > iii) How do I de-install the 8.01.0200 driver? The usual way
> > of working from
> >      NT's control panel applet simply reinstalls it.
> 
> That works fine on 2K/XP/2K3, but I've never tried on NT. You could try:
> 
> msiexec uninstall psqlodbc.msi

I can confirm after another test that NT's control panel "Add/Remove" goes
through an unprompted install ending up with the congratulations dialogue.

Running the command as above... any attempt to run msiexec from the command line
or to execute psqlodbc.msi (relying on its association) with parameters results
in an "Incorrect command line parameters" box reporting v 2.00.2600.2. Frankly
I'm not entirely sure how this version got onto the machines- I suspect with
v7's ODBC.

Courtesy of Google hence
http://www.installshield.com/news/newsletter/0411-articles/msiexec.asp, the
format appears to be

msiexec /x psqlodbc.msi

I note that according to that URL appending /qf should display "Full Wizard"
dialogues, but instead it appears to something odd like a silent de-install with
a final "installed" dialogue :-/

-- 
Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

In response to

Responses

pgsql-odbc by date

Next:From: Hiroshi InoueDate: 2006-08-28 01:00:02
Subject: Re: [COMMITTERS] psqlodbc - psqlodbc: Fixed dllname of win32
Previous:From: Dave PageDate: 2006-08-27 20:13:36
Subject: Re: Latest ODBC driver?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group