I have a PL/Java bug entry from Peter E. that reads "It is customary in PostgreSQL land and
elsewhere, that dynamically loadable modules do not have a lib prefix (compare plpgsql.so,
pltcl.so, etc.). So I suggest that the shared object installed by PL/Java also be called
I'd like to follow customary practices but as it turns out, I'm not the one adding the 'lib'
prefix. It's done by the Makefile.shlib that comes bundled with pgxs. Here you can read
# Default shlib naming convention used by the majority of platforms
shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
shlib_major = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
shlib_bare = lib$(NAME)$(DLSUFFIX)
and sure enough, that's what gets used too. So what goes?
Personally, I'd prefer to keep the 'lib' prefix since it really *is* the default naming
convention on all *n[iu]x platforms I've been in contact with. Not so on Windows though so
perhaps that should change in Makefile.shlib?
pgsql-hackers by date
|Next:||From: Martin Pitt||Date: 2006-02-25 12:46:48|
|Subject: Re: Adding an ignore list to pg_restore, prototype patch #1|
|Previous:||From: Hannu Krosing||Date: 2006-02-25 11:38:40|
|Subject: Re: Pl/Python -- current maintainer?|