Skip site navigation (1) Skip section navigation (2)

Re: [PATCH] acinclude.m4 fixes for wx 2.6, wx-nondebug,

From: "Florian G(dot) Pflug" <fgp(at)phlo(dot)org>
To: Chris Campbell <chris(at)bignerdranch(dot)com>
Cc: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: [PATCH] acinclude.m4 fixes for wx 2.6, wx-nondebug,
Date: 2005-04-15 15:28:05
Message-ID: 425FDD85.7080402@phlo.org (view raw or flat)
Thread:
Lists: pgadmin-hackers
Chris Campbell wrote:
> I compiled CVS HEAD against a non-debug wxMac 2.5.5 (with toplevel.cpp 
> patch). Compiled successfully out of the box. And it doesn't have the 
> window sizing problem. However, I do get a big blank error window if I 
> attempt to connect to a server and it rejects the connection (incorrect 
> password, etc).
> 
> I put my build up at:
> 
>    http://gwenmalone.com/pgAdmin3.tar.gz (4.8 MB)
> 
> if anyone wants to try it.
> 
> BTW, why don't we just link against the static libpq.a? Then we don't 
> need Frameworks/libpq.4.dylib, and we can probably make the whole thing 
> a bit smaller. Right now, it's a total of about 18 MB, with all the docs 
> and everything (executable size is about 7 MB). The description of this 
> patch seems to imply that we are linking against libpq statically, but I 
> see "-lpq" in the linker flags when we link the executable.

Hm.. it links libpq statically for me (that was the main reason I had
to fix the ssl-detection problem. If libpq was linked against libssl,
then each app that links _statically_ against libpq has to link
against libssl as well, because otherwise libpq has unresolved symbols.
If you link libpq dynamically, it can pull in libssl, even when the app
doesn't like against libssl)

Thats the configure options I used for pgadmin...

CPPFLAGS="-DwxUSE_DEPRECATED=0" \
./configure \
         --enable-appbundle \
         --enable-static \
         --with-wx=$WXWIDGETS_INST_DIR \
                 --with-wx-config=bin/wx-config \
         --with-pgsql=$PGSQL_INST_DIR \ 


greetings, Florian Pflug

In response to

pgadmin-hackers by date

Next:From: OpenMacNewsDate: 2005-04-15 15:30:54
Subject: Re: pgadmin3 + wxwidgets-cvs (v2.6) ; dies in
Previous:From: Florian G. PflugDate: 2005-04-15 15:17:15
Subject: Re: pgadmin3 + wxwidgets-cvs (v2.6) ; dies in 'install-exec-hook"

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group