Skip site navigation (1) Skip section navigation (2)

Re: PostgreSQL 8.0.0beta2 compile error with Sun CC.

From: Mark Round <mark(at)markround(dot)com>
To: pgsql-ports(at)postgresql(dot)org
Subject: Re: PostgreSQL 8.0.0beta2 compile error with Sun CC.
Date: 2004-09-24 15:33:25
Message-ID: 41543E45.4010306@markround.com (view raw or flat)
Thread:
Lists: pgsql-ports
>We heard about this before, but the previous complainant didn't answer
>the obvious followup question: which versions of Solaris will fail if we
>change it to ".section"?  Or more to the point, how can we #ifdef the
>code so that this works on all Solaris versions?
>  
>
Hi,

If it is changed to ".section", any SunOS 4.1.x -based (pre-1992) system 
will fail to compile it.

I am guessing here (not a programmer), but as the ".seg" pseudo-op was a 
SunOS 4.1.x construct, you could probably check for a 5.x version of 
SunOS, and in which case, set the lines to ".section". I am not sure 
what the appropriate #ifdef lines should look like, but will try to find 
out for you.

-Mark

In response to

Responses

pgsql-ports by date

Next:From: Tom LaneDate: 2004-09-24 15:40:06
Subject: Re: PostgreSQL 8.0.0beta2 compile error with Sun CC.
Previous:From: Tom LaneDate: 2004-09-24 14:42:18
Subject: Re: PostgreSQL 8.0.0beta2 compile error with Sun CC.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group