Tom Lane wrote:
> I thought llast() and length() were going away too?
For llast(), I decided to keep it around: it is nicely symmetric
with linitial(), and it makes any code that actually needs the last
value in a list significantly more readable. Since it's a macro
there's no runtime cost.
I had thought about keeping length() around, but on second thought I
don't see why we ought to. I'll replace it with list_length() and
post an updated patch.
In response to
pgsql-patches by date
|Next:||From: Neil Conway||Date: 2004-05-30 21:09:44|
|Subject: Re: use new List API names|
|Previous:||From: Tom Lane||Date: 2004-05-30 16:03:08|
|Subject: Re: use new List API names |