Skip site navigation (1) Skip section navigation (2)

V7.4.2: drop database does not drop schemas/table/data

From: Rachel Willmer <rachel(at)willmer(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: V7.4.2: drop database does not drop schemas/table/data
Date: 2004-05-11 11:14:04
Message-ID: 40A0B57C.6010300@willmer.com (view raw or flat)
Thread:
Lists: pgsql-bugs
I have a database 'testdb' with two schemas: 'public' and edinburgh'. 
Public is empty, everything is in 'edinburgh'.

DROP DATABASE testdb;

Database no longer appears in list of databases in cluster. So far, so good.

CREATE DATABASE testdb;

Database appears again. But so does the schema 'edinburgh', all its 
tables, views, data, etc.

 From reading the documentation, I thought that "DROP DATABASE" also 
deleted all the underlying objects. In which case, this is a bug.

BTW, this is my first post of a postgresql bug. It would be useful if 
your page 
<http://www.postgresql.org/docs/current/static/bug-reporting.html> had a 
link to where the "TODO LIST" and "FAQ" files can be found - it's not 
obvious unless you already know!

Thanks
Rachel

PS: System is PostgreSQL 7.4.2 on i686-pc-linux-gnu, compiled by GCC gcc 
(GCC) 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3-3-7)


Responses

pgsql-bugs by date

Next:From: Tom LaneDate: 2004-05-11 11:44:42
Subject: Re: missing support for using regex and arrays
Previous:From: Martin PittDate: 2004-05-11 10:03:58
Subject: Fwd: Bug#247306: odbc-postgresql: SIGSEGV with long inputs (> 10000 bytes)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group