Skip site navigation (1) Skip section navigation (2)

Re: RPM package question

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: John Gardner <john(dot)gardner(at)tagish(dot)co(dot)uk>
Cc: pgsql-novice(at)postgresql(dot)org
Subject: Re: RPM package question
Date: 2009-04-03 13:52:41
Message-ID: 28227.1238766761@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-novice
John Gardner <john(dot)gardner(at)tagish(dot)co(dot)uk> writes:
> We've got an application to install on PostgreSQL 8.2 and the
> requirements say "Please make sure that PL/pgsql and FuzzyStringMatch
> library is installed."

> Can anyone tell me which RPM packages contain these?

Hmm, I'm pretty sure Devrim's packages split up the same way mine do,
so the answer should be -server and -contrib respectively.  Which
you've got.  You probably just haven't activated them in your current
database.  To install plpgsql you say "CREATE LANGUAGE plpgsql".
To install a contrib module you run its defining SQL script, which if
memory serves is under /usr/share/pgsql/contrib/ (if not, rpm -ql
on the -contrib RPM will tell you where they are).

			regards, tom lane

In response to

Responses

pgsql-novice by date

Next:From: John GardnerDate: 2009-04-04 08:19:41
Subject: Re: RPM package question
Previous:From: Tom LaneDate: 2009-04-03 13:44:15
Subject: Re: RPM for CentOS

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group