Skip site navigation (1) Skip section navigation (2)

pgsql: Make the win32 putenv() override update *all* present versions of

From: mha(at)postgresql(dot)org (Magnus Hagander)
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: Make the win32 putenv() override update *all* present versions of
Date: 2010-01-01 14:57:16
Message-ID: 20100101145716.7EE2A753FB7@cvs.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-committers
Log Message:
-----------
Make the win32 putenv() override update *all* present versions of the
MSVCRxx runtime, not just the current + Visual Studio 6 (MSVCRT). Clearly
there can be an almost unlimited number of runtimes loaded at the same
time.

Per report from Hiroshi Inoue

Modified Files:
--------------
    pgsql/src/port:
        win32env.c (r1.5 -> r1.6)
        (http://anoncvs.postgresql.org/cvsweb.cgi/pgsql/src/port/win32env.c?r1=1.5&r2=1.6)

pgsql-committers by date

Next:From: Magnus HaganderDate: 2010-01-01 14:57:19
Subject: pgsql: Make the win32 putenv() override update *all* present versions of
Previous:From: Tom LaneDate: 2009-12-31 22:11:10
Subject: pgsql: Suppress compiler warning, per buildfarm member narwhal

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group