Skip site navigation (1) Skip section navigation (2)

BUG #5137: Upgrade policy clarification

From: "Peter Bengtson" <peter(at)peterbengtson(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: BUG #5137: Upgrade policy clarification
Date: 2009-10-25 13:52:01
Message-ID: 200910251352.n9PDq1VH008217@wwwmaster.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-bugs
The following bug has been logged online:

Bug reference:      5137
Logged by:          Peter Bengtson
Email address:      peter(at)peterbengtson(dot)com
PostgreSQL version: 8.3.8
Operating system:   Debian, Mac OS X
Description:        Upgrade policy clarification
Details: 

It would be good if you to the page describing how a db dump is required
only for major verson upgrades, e.g. from 8.3.x to 8.4.x but not from, say,
8.3.7 to 8.3.8, could add a proviso: a DB dump *is* necessary when upgrading
from a server compiled for 32 bits even to the same version compiled for 64
bit architectures.

I recently spent about 12 hours getting my development system in order again
after an upgrade from Leopard to Snow Leopard, simply because I believed
your upgrade policy page. It would be nice if other people didn't have to go
through that process.

Responses

pgsql-bugs by date

Next:From: Timothy MaddenDate: 2009-10-25 16:09:12
Subject: Re: BUG #5136: Please drop the string literal syntax for CREATE FUNCTION ...
Previous:From: Peter EisentrautDate: 2009-10-25 10:42:40
Subject: Re: BUG #5136: Please drop the string literal syntax for CREATE FUNCTION ...

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group