Skip site navigation (1) Skip section navigation (2)

pgsql: Document the fix for perl 5.10 with this comment: * The

From: adunstan(at)postgresql(dot)org (Andrew Dunstan)
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: Document the fix for perl 5.10 with this comment: * The
Date: 2008-01-23 00:55:47
Message-ID: 20080123005547.E112D754108@cvs.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-committers
Log Message:
-----------
Document the fix for perl 5.10 with this comment:
 * The temporary enabling of the caller opcode here is to work around a
 * bug in perl 5.10, which unkindly changed the way its Safe.pm works, without
 * notice. It is quite safe, as caller is informational only, and in any case
 * we only enable it while we load the 'strict' module.

Modified Files:
--------------
    pgsql/src/pl/plperl:
        plperl.c (r1.135 -> r1.136)
        (http://developer.postgresql.org/cvsweb.cgi/pgsql/src/pl/plperl/plperl.c?r1=1.135&r2=1.136)

Responses

pgsql-committers by date

Next:From: Tom LaneDate: 2008-01-23 02:04:47
Subject: pgsql: Reference pgAdmin as a typical client-side tool, rather than the
Previous:From: Andrew DunstanDate: 2008-01-22 23:32:53
Subject: Re: pgsql: Work around for perl 5.10 bug - fix due to perl hacker Simon

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group