Skip site navigation (1) Skip section navigation (2)

Re: [HACKERS] Fix linking of OpenLDAP libraries

From: Martijn van Oosterhout <kleptog(at)svana(dot)org>
To: Albe Laurenz <all(at)adv(dot)magwien(dot)gv(dot)at>
Cc: Tom Lane *EXTERN* <tgl(at)sss(dot)pgh(dot)pa(dot)us>, pgsql-hackers(at)postgresql(dot)org,pgsql-patches(at)postgresql(dot)org
Subject: Re: [HACKERS] Fix linking of OpenLDAP libraries
Date: 2006-09-11 11:20:55
Message-ID: 20060911112055.GC10843@svana.org (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
On Mon, Sep 11, 2006 at 12:13:29PM +0200, Albe Laurenz wrote:
> > Applied, but without that last part.  It builds OK for me on Darwin,
> > which is moderately picky about that sort of thing, but someone should
> > try AIX.
> 
> It builds fine on AIX 5.3 as long as you tell it to link with
> libpq.so. Static builds against libpq.a will fail.
> 
> Should -lldap or -lldap_r be added to pg_config --libs?
> If yes, which of them?

Static links are going to require it on every platform, not just AIX.
The question do we want to ask is how easy do we want to make static
linking, because the same treatment will have to apply to -lssl,
-lcrypto, -lkrb5, -lk5crypto and quite possibly others. Do we really
want to go there?

Have a nice day,
-- 
Martijn van Oosterhout   <kleptog(at)svana(dot)org>   http://svana.org/kleptog/
> From each according to his ability. To each according to his ability to litigate.

In response to

Responses

pgsql-hackers by date

Next:From: Chander GanesanDate: 2006-09-11 11:37:37
Subject: Re: Training (from Thought provoking...)
Previous:From: Albe LaurenzDate: 2006-09-11 10:13:29
Subject: Re: [HACKERS] Fix linking of OpenLDAP libraries

pgsql-patches by date

Next:From: Tom LaneDate: 2006-09-11 13:42:24
Subject: Re: [HACKERS] Fix linking of OpenLDAP libraries
Previous:From: Albe LaurenzDate: 2006-09-11 10:13:29
Subject: Re: [HACKERS] Fix linking of OpenLDAP libraries

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group