Skip site navigation (1) Skip section navigation (2)

[ psqlodbc-Bugs-1000692 ] Broken UTF-8 support in Version 08.02.0002

From: <noreply(at)pgfoundry(dot)org>
To: noreply(at)pgfoundry(dot)org
Subject: [ psqlodbc-Bugs-1000692 ] Broken UTF-8 support in Version 08.02.0002
Date: 2006-07-28 07:14:21
Message-ID: 20060728071421.8A3EC86C674@pgfoundry.org (view raw or flat)
Thread:
Lists: pgsql-odbc
Bugs item #1000692, was opened at 2006-07-28 07:14
You can respond by visiting: 
http://pgfoundry.org/tracker/?func=detail&atid=538&aid=1000692&group_id=1000125

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Nobody (None)
Assigned to: Nobody (None)
Summary: Broken UTF-8 support in Version 08.02.0002

Initial Comment:
I have an english Windows 2000 with this driver, that connects to a 8.1.4 postgres DB. Previous I use the 7.4 version.

With the old driver (I guess some 7 version, I cannot find the exat string) I could connect to 7.4 version and get UTF-8 data (in this case japanese) without any issues. I added the "SET client_encoding TO 'UTF-8' in my db connect script.

Once I upgraded to the new driver I just get ??? back from the db. From both, either the 8.1 or the 7.4. I tried the old driver on the new db, but that doesn't work either.

I also tried the Postgres "UNICODE" driver, but there I get also just ??? back.

So I had to revert my upgrade for now. Is there any debug data I can provide? Client or Server side? 



----------------------------------------------------------------------

You can respond by visiting: 
http://pgfoundry.org/tracker/?func=detail&atid=538&aid=1000692&group_id=1000125

pgsql-odbc by date

Next:From: noreplyDate: 2006-07-28 07:23:46
Subject: [ psqlodbc-Bugs-1000692 ] Broken UTF-8 support in Version 08.02.0002
Previous:From: Pascal ViandierDate: 2006-07-27 19:53:32
Subject: Problems updating rows

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group