Skip site navigation (1) Skip section navigation (2)

Re: ruby/postgres - getting assoc array of rows?

From: CSN <cool_screen_name90001(at)yahoo(dot)com>
To: Michael Fuhr <mike(at)fuhr(dot)org>
Cc: pgsql-interfaces(at)postgresql(dot)org
Subject: Re: ruby/postgres - getting assoc array of rows?
Date: 2005-11-22 08:49:32
Message-ID: 20051122084932.93180.qmail@web52901.mail.yahoo.com (view raw or flat)
Thread:
Lists: pgsql-interfaces
It looks like the snapshot version causes problems for Rails :(

http://dev.rubyonrails.org/ticket/2977
http://www.ruby-forum.com/topic/9114#new

reals and numerics get converted to values like nil, 1, 2, true, ...

I had to uninstall it and go back to the 0.71 version. The postgres.so files get installed in
different locations - perhaps I can configure Rails and commandline scripts to load the one they
need.

csn


--- Michael Fuhr <mike(at)fuhr(dot)org> wrote:

> On Sun, Nov 20, 2005 at 12:28:32PM -0800, CSN wrote:
> > Ah.. I installed the snapshot manually and the script works fine now.
> > They should update the gem version - Jan. 2003 is quite a while ago.
> > Does it matter if the postgres library is installed via 'gem' or not?
> 
> I wouldn't think so, except maybe for how your program loads the
> code (require vs. require_gem).
> 
> -- 
> Michael Fuhr
> 



		
__________________________________ 
Yahoo! FareChase: Search multiple travel sites in one click.
http://farechase.yahoo.com

In response to

pgsql-interfaces by date

Next:From: Bruce MomjianDate: 2005-11-22 22:32:37
Subject: Re: Not clear on what PQgetResult does
Previous:From: Michael FuhrDate: 2005-11-21 02:04:02
Subject: Re: ruby/postgres - getting assoc array of rows?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group