Am Sonntag, 25. Juli 2004 01:48 schrieb Tom Lane:
> One issue is that it may break existing PLs that override Warn_restart,
> since the semantics of doing that will have changed a bit. We can
> easily fix the PLs that are in our own CVS, but what are the
> implications for other PLs such as PL/R and PL/SH? Joe, Peter, any
PL/sh is OK, but both PL/Ruby and PL/Java play around with Warn_restart.
> I am somewhat tempted to rename the setjmp variable Warn_restart to
> something else, so as to catch any code that is still expecting the
> old behavior (besides, it was never a very good name anyway). On the
> other hand, there may be cases where a PL's code doesn't actually need
> to change, and if so a rename would just break it unnecessarily. Any
> votes which way to jump?
Maybe the authors (in Cc) can comment what support they need.
In response to
pgsql-hackers by date
|Next:||From: Tom Lane||Date: 2004-07-29 14:47:55|
|Subject: Re: Sketch of extending error handling for subtransactions in functions |
|Previous:||From: Tom Lane||Date: 2004-07-29 14:12:22|
|Subject: Re: more signals (was: Function to kill backend) |