Skip site navigation (1) Skip section navigation (2)

patch: contrib/pgcrypto sanity

From: Marko Kreen <marko(at)l-t(dot)ee>
To: pgsql-hackers(at)postgresql(dot)org
Subject: patch: contrib/pgcrypto sanity
Date: 2001-01-08 00:37:51
Message-ID: 20010108023751.A4692@l-t.ee (view raw or flat)
Thread:
Lists: pgsql-hackers
The KAME files md5.* and sha1.* have the following changelog
entry:

----------------------------
revision 1.2
date: 2000/12/04 01:20:38;  author: tgl;  state: Exp;  lines:
+18 -18
Eliminate some of the more blatant platform-dependencies ... it
builds here now, anyway ...
----------------------------

Which basically changes u_int*_t -> uint*_t, so now it does not
compile neither under Debian 2.2 nor under NetBSD 1.5 which
is platform independent¸ all right.  Also it replaces $KAME$
with $Id$ which is Bad Thing. PostgreSQL Id should be added as a
separate line so the file history could be seen.

So here is patch:

* changes uint*_t -> uint*.  I guess that was the original
  intention
* adds uint64 type to include/c.h because its needed
  [somebody should check if I did it right]
* adds back KAME Id, because KAME is the master repository
* removes stupid c++ comments in pgcrypto.c
* removes <sys/types.h> from the code, its not needed

-- 
marko

Responses

pgsql-hackers by date

Next:From: Christopher Kings-LynneDate: 2001-01-08 01:02:55
Subject: RE: Suggested fix for pg_dump
Previous:From: bpalmerDate: 2001-01-07 22:34:14
Subject: Re: CVS regression test failure on OBSD

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group