Skip site navigation (1) Skip section navigation (2)

Re: [HACKERS] v6.4-BETA3 problems with FreeBSD

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: SHIOZAKI Takehiko <takehi-s(at)ascii(dot)co(dot)jp>
Cc: pgsql-hackers(at)postgreSQL(dot)org
Subject: Re: [HACKERS] v6.4-BETA3 problems with FreeBSD
Date: 1998-10-30 04:41:41
Message-ID: 17624.909722501@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackers
SHIOZAKI Takehiko <takehi-s(at)ascii(dot)co(dot)jp> writes:
> * Makefile.shlib
> 	FreeBSD is not supported.

Can you provide an appropriate entry to add to Makefile.shlib for
FreeBSD?  It's probably much like one of the existing entries...

> gmake[3]: Entering directory `/usr/local/src/postgresql.v6.4-BETA3/pgsql/src/pl/
> plpgsql/src'
> /usr/bin/install -c -m 644  /usr/local/pgsql/lib/plpgsql.so
> usage: install [-CcDps] [-f flags] [-g group] [-m mode] [-o owner] file1 file2
>        install [-CcDps] [-f flags] [-g group] [-m mode] [-o owner] file1 ...
>              fileN directory
>        install -d [-g group] [-m mode] [-o owner] directory ...
> gmake[3]: *** [install] Error 64

Oops.  The plpgsql Makefile should exit a little more gracefully on
a system not supported by Makefile.shlib.  I'll do something about
that tomorrow.

			regards, tom lane

Responses

pgsql-hackers by date

Next:From: Tom LaneDate: 1998-10-30 04:44:01
Subject: Re: [HACKERS] v6.4-BETA3 problems with FreeBSD
Previous:From: The Hermit HackerDate: 1998-10-30 04:21:28
Subject: Re: [HACKERS] flock patch breaks things here

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group