Skip site navigation (1) Skip section navigation (2)

Re: configure doesn't detect SSL support in libpq

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Dave Page <dpage(at)pgadmin(dot)org>
Cc: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: configure doesn't detect SSL support in libpq
Date: 2011-12-12 23:03:22
Message-ID: 1323731002.4359.51.camel@localhost.localdomain (view raw or flat)
Thread:
Lists: pgadmin-hackers
On Tue, 2011-12-13 at 04:20 +0530, Dave Page wrote:
> On Tue, Dec 13, 2011 at 2:48 AM, Guillaume Lelarge
> <guillaume(at)lelarge(dot)info> wrote:
> > Hi,
> >
> > It seems our configure script doesn't detect SSL support in libpq. It
> > detects the SSL library though.
> >
> > The following patch fixes it, but I'm not sure of it as I'm in no way an
> > expert in those things;
> >
> > diff --git a/acinclude.m4 b/acinclude.m4
> > index 4030966..0640a68 100644
> > --- a/acinclude.m4
> > +++ b/acinclude.m4
> > @@ -538,7 +538,7 @@ AC_DEFUN([SETUP_POSTGRESQL],
> >                                        PG_SSL="no"
> >                                fi
> >                        else
> > -                               AC_CHECK_LIB(pq, SSL_connect,
> > [PG_SSL=yes], [PG_SSL=no])
> > +                               AC_CHECK_LIB(pq, SSL_connect,
> > [PG_SSL=yes], [PG_SSL=no], "-lssl")
> >                        fi
> >                fi
> >                else
> >
> > Any comments would be appreciated :)
> 
> What exactly are you trying to fix? I spent quite a while on this last
> cycle and though I'd ironed out all the wrinkles. Note that -lssl
> isn't always enough - on some platforms you'll also need -lcrypt (or
> -lcrypto, I forget which).
> 

Well, without this patch, I always get a "PostgreSQL SSL support:
Missing" message after configure. config.log shows this:

configure:5737: gcc -o conftest -g -O2   -L/opt/postgresql-head/lib
conftest.c -lpq   >&5 
/usr/bin/ld: /tmp/ccAr1HM4.o: undefined reference to symbol
'SSL_connect'
/usr/bin/ld: note: 'SSL_connect' is defined in
DSO /usr/lib64/libssl.so.10 so try adding it to the linker command line
/usr/lib64/libssl.so.10: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

My full config.log is attached.

And actually, I'm not alone having issues with SSL. See
https://bugs.launchpad.net/ubuntu/+source/pgadmin3/+bug/780565.


-- 
Guillaume
  http://blog.guillaume.lelarge.info
  http://www.dalibo.com

Attachment: config.log.bz2
Description: application/x-bzip (6.6 KB)

In response to

Responses

pgadmin-hackers by date

Next:From: Guillaume LelargeDate: 2011-12-13 07:24:25
Subject: Re: configure doesn't detect SSL support in libpq
Previous:From: Dave PageDate: 2011-12-12 22:50:17
Subject: Re: configure doesn't detect SSL support in libpq

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group