Skip site navigation (1) Skip section navigation (2)

pgadmin3 1.6.1 build error on FC6

From: Devrim GUNDUZ <devrim(at)CommandPrompt(dot)com>
To: "pgadmin-hackers(at)postgresql(dot)org" <pgadmin-hackers(at)postgresql(dot)org>
Subject: pgadmin3 1.6.1 build error on FC6
Date: 2006-12-20 21:43:20
Message-ID: 1166651000.3075.22.camel@laptop.gunduz.org (view raw or flat)
Thread:
Lists: pgadmin-hackers
Hi,

I'm trying to build 1.6.1 RPM on FC6 (Yes, I built wx on FC6). I got
this error:

<snip>

rm -f ".deps/frmEditGrid.Tpo"; exit 1; fi
/usr/include/wx-2.8/wx/hashmap.h: In member function 'wxLongToLongHashMap_wxImplementation_HashTable::Node** wxLongToLongHashMap_wxImplementation_HashTable::GetNodePtr(const long int&) const':
/usr/include/wx-2.8/wx/hashmap.h:714: warning: dereferencing type-punned pointer will break strict-aliasing rules
/usr/include/wx-2.8/wx/clntdata.h: In member function 'wxShadowObjectMethods_wxImplementation_HashTable::Node** wxShadowObjectMethods_wxImplementation_HashTable::GetNodePtr(const wxString&) const':
/usr/include/wx-2.8/wx/clntdata.h:20: warning: dereferencing type-punned pointer will break strict-aliasing rules
/usr/include/wx-2.8/wx/clntdata.h: In member function 'wxShadowObjectFields_wxImplementation_HashTable::Node** wxShadowObjectFields_wxImplementation_HashTable::GetNodePtr(const wxString&) const':
/usr/include/wx-2.8/wx/clntdata.h:25: warning: dereferencing type-punned pointer will break strict-aliasing rules
/usr/include/wx-2.8/wx/gdicmn.h: In member function 'wxStringToColourHashMap_wxImplementation_HashTable::Node** wxStringToColourHashMap_wxImplementation_HashTable::GetNodePtr(const wxString&) const':
/usr/include/wx-2.8/wx/gdicmn.h:540: warning: dereferencing type-punned pointer will break strict-aliasing rules
/usr/include/wx-2.8/wx/image.h: In member function 'wxImageHistogramBase_wxImplementation_HashTable::Node** wxImageHistogramBase_wxImplementation_HashTable::GetNodePtr(const long unsigned int&) const':
/usr/include/wx-2.8/wx/image.h:136: warning: dereferencing type-punned pointer will break strict-aliasing rules
/usr/include/wx-2.8/wx/filesys.h: In member function 'wxFSHandlerHash_wxImplementation_HashTable::Node** wxFSHandlerHash_wxImplementation_HashTable::GetNodePtr(const void* const&) const':
/usr/include/wx-2.8/wx/filesys.h:176: warning: dereferencing type-punned pointer will break strict-aliasing rules
./frm/frmEditGrid.cpp: At global scope:
./frm/frmEditGrid.cpp:78: error: 'EVT_AUI_PANEBUTTON' was not declared in this scope
./frm/frmEditGrid.cpp:79: error: expected `}' before 'wxEventTableEntry'
./frm/frmEditGrid.cpp:79: error: expected ',' or ';' before 'wxEventTableEntry'
./frm/frmEditGrid.cpp:79: error: expected declaration before '}' token
../src/include/images/viewdata.xpm:2: warning: 'viewdata_xpm' defined but not used
../src/include/images/storedata.xpm:2: warning: 'storedata_xpm' defined but not used
../src/include/images/readdata.xpm:2: warning: 'readdata_xpm' defined but not used
../src/include/images/delete.xpm:2: warning: 'delete_xpm' defined but not used
../src/include/images/edit_undo.xpm:2: warning: 'edit_undo_xpm' defined but not used
../src/include/images/sortfilter.xpm:2: warning: 'sortfilter_xpm' defined but not used
../src/include/images/help.xpm:2: warning: 'help_xpm' defined but not used
../src/include/images/clip_copy.xpm:2: warning: 'clip_copy_xpm' defined but not used
../src/include/images/clip_paste.xpm:2: warning: 'clip_paste_xpm' defined but not used
make[2]: *** [frmEditGrid.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/pgadmin3-1.6.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/pgadmin3-1.6.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.81943 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.81943 (%build)

The environment is:

$ rpm -qv wxGTK-devel
wxGTK-devel-2.8.0-2.8.0.1.3

$ wx-config --list

    Default config is gtk2-unicode-release-static-2.6

  Default config will be used for output

  Alternate matches:
    gtk2-unicode-debug-2.6
    gtk2-unicode-debug-static-2.6
    gtk2-unicode-release-2.6


and configure options are:
 --disable-debug --with-wx-version=2.8 --with-wx=/usr


Any comments?


Regards,
-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, plPerlNG - http://www.commandprompt.com/




Responses

pgadmin-hackers by date

Next:From: Dave PageDate: 2006-12-20 21:48:32
Subject: Re: pgadmin3 1.6.1 build error on FC6
Previous:From: svnDate: 2006-12-18 14:02:48
Subject: SVN Commit by hiroshi: r5801 - trunk/pgadmin3/pkg/suse

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group