Skip site navigation (1) Skip section navigation (2)

Mac OS 10.7x ??

From: Brian Hamlin <maplabs(at)light42(dot)com>
To: psycopg(at)postgresql(dot)org
Subject: Mac OS 10.7x ??
Date: 2012-02-15 07:27:29
Message-ID: (view raw or whole thread)
Lists: psycopg
Hi All -

   I am configuring a Mac laptop to use for coding, and of course I  
wanted psycopg2 right away..
But the more I look into this, the more questions are raised..

   I do not want to use the hack to turn off 64-bit python.. why ??
If I am not using Python 3 than at least I should be able to keep 64  
bit, no?

   The system Postgres is well hidden.. I installed PgAdmin 3  
via .dmg and I have no
problems there.. there is a libpq private to PgAdmin

   but the pg_config that is found in /usr/bin appears to be for the  
hidden Postgres
I have stopped my installs at this point, other than a few KyngChaos  
for geo processing.. like QGis..

   what is the story ?  Is Mac OS X an orphan now?
   (I believe I am similarly stuck with no ipython, also)

Brian Hamlin
OSGeo California Chapter
415-717-4462 cell

In response to

psycopg by date

Next:From: Rehan SaleemDate: 2012-03-09 12:00:37
Subject: How to call Postgresql Array Function in Python
Previous:From: Federico Di GregorioDate: 2012-02-14 13:28:16
Subject: Re: libpq custom row processing

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group