Skip site navigation (1) Skip section navigation (2)

Error during update from version 6.5.3 to version 7.03

From: José Luiz <jlp(at)macknight(dot)com(dot)br>
To: <pgsql-novice(at)postgresql(dot)org>
Subject: Error during update from version 6.5.3 to version 7.03
Date: 2001-03-30 23:22:41
Message-ID: 001b01c0b970$50f0adc0$0a00a8c0@maclinux (view raw or flat)
Thread:
Lists: pgsql-novice
I made a download of postgresql packages .rpm for suse64.

I stoped postgresql and started to install the packages.

The first package I tried to install was   postgres-7.0.3-1suse64-i386.rpm

I received 1 error:
failed dependencies
pg_lib = 7.0.3 is needed by postgres-7.0.3-1suse64
libpq.so.2.1    is needed by postgres-7.0.3-1suse64

So, I tried to install package    pg_lib-7.0.3-1suse64.i386.rpm
I received 7 erros:
file /usr/lib/libecpg.so from install of pg_lib-7.0.3-1suse64 conflicts with
file from package pg_ifa-6.5.3-46
file /usr/lib/libecpg.so.3 from install of pg_lib-7.0.3-1suse64 conflicts
with file from package pg_ifa-6.5.3-46
file /usr/lib/libpg++.so from install of pg_lib-7.0.3-1suse64 conflicts with
file from package pg_ifa-6.5.3-46
file /usr/lib/libpg++.so.3 from install of pg_lib-7.0.3-1suse64 conflicts
with file from package pg_ifa-6.5.3-46
file /usr/lib/libpg.so from install of pg_lib-7.0.3-1suse64 conflicts with
file from package pg_ifa-6.5.3-46
file /usr/lib/libpg.so.2 from install of pg_lib-7.0.3-1suse64 conflicts with
file from package pg_ifa-6.5.3-46
file /usr/lib/libpg.so.2.0 from install of pg_lib-7.0.3-1suse64 conflicts
with file from package pg_ifa-6.5.3-46


What is the right order to install these packages ?

José Luiz Pedroza
jlp(at)macknight(dot)com(dot)br


Responses

pgsql-novice by date

Next:From: ADBAAMDDate: 2001-03-30 23:46:57
Subject: Re: Error during update from version 6.5.3 to version 7.03
Previous:From: IGB.NETDate: 2001-03-30 20:51:20
Subject:

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group