Skip site navigation (1) Skip section navigation (2)

I can't upgrade to PostgreSQL 7.4 in RedHat 9.0

From: "Manuel Tejada" <mantemu(at)terra(dot)com(dot)pe>
To: <pgsql-general(at)postgresql(dot)org>
Subject: I can't upgrade to PostgreSQL 7.4 in RedHat 9.0
Date: 2004-01-25 03:38:47
Message-ID: 001301c3e2f4$be1439c0$020aa8c0@alejo (view raw or flat)
Thread:
Lists: pgsql-general
Hello list

This is my situation:

My box: Pentium III, Red Hat 9.0

I was working fine with PostgreSQL 7.3.2.
Recently I decided to upgrade it to PostgreSQL 7.4 installing the twelve
rpms I downloaded from
ftp://ftp15.us.postgresql.org/binar...dhat/refhat-9/.

I followed the standar command to upgrade rpm packages but the installation
failed due to conflicts with the installed package unixODBC-devel-2.2.3-6.

This is the output I got from the system:
-------------------------------------------
#rpm -Uvh postgresql*7.4-0.5PGDG.i386.rpm
Preparing... ########################[100%]
file /usr/include/sqltypes.h from install of postgresql-devel-7.4-0.5PGDG
conflicts with file from package unixODBC-devel-2.2.3-6
----------------------------------------------

At first solution I tried to uninstall unixODBC (composed by two rpms:
unixODBC-2.2.3-06 and unixODBC-devel-2.2.3-6) but failed due to dependence
with the package libodbc++-0.2.2pre4-12 ( an ODBC class library that
emulates the JBBC interface). So, I change my mind because I fear to enter
in an endless upgrading.

My questions are:

a)What must I do to upgrade from PostgreSQL 7.3.2 I to PostgreSQL 7.4 in Red
Hat 9.0?.
b) If it is neccesary to upgrade the package unixODBC, where I can get the
rpm and what is the
correct version.?


I really hope someone can give me a hand.


Responses

pgsql-general by date

Next:From: Russell ShawDate: 2004-01-25 05:06:46
Subject: Multiway associations
Previous:From: Bruce MomjianDate: 2004-01-25 02:29:12
Subject: Re: FAQ (disk space)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group