This page in other versions: 8.4 / 9.0 / 9.1 / 9.2 / 9.3  |  Development versions: devel  |  Unsupported versions: 7.3 / 7.4 / 8.0 / 8.1 / 8.2 / 8.3

E.119. Release 7.3.9

Release date: 2005-01-31

This release contains a variety of fixes from 7.3.8, including several security-related issues.

E.119.1. Migration to Version 7.3.9

A dump/restore is not required for those running 7.3.X.

E.119.2. Changes

  • Disallow LOAD to non-superusers

    On platforms that will automatically execute initialization functions of a shared library (this includes at least Windows and ELF-based Unixen), LOAD can be used to make the server execute arbitrary code. Thanks to NGS Software for reporting this.

  • Check that creator of an aggregate function has the right to execute the specified transition functions

    This oversight made it possible to bypass denial of EXECUTE permission on a function.

  • Fix security and 64-bit issues in contrib/intagg

  • Add needed STRICT marking to some contrib functions (Kris Jurka)

  • Avoid buffer overrun when plpgsql cursor declaration has too many parameters (Neil)

  • Fix planning error for FULL and RIGHT outer joins

    The result of the join was mistakenly supposed to be sorted the same as the left input. This could not only deliver mis-sorted output to the user, but in case of nested merge joins could give outright wrong answers.

  • Fix plperl for quote marks in tuple fields

  • Fix display of negative intervals in SQL and GERMAN datestyles

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group