Skip site navigation (1) Skip section navigation (2)

Slony-I (Production Grade) Replication System Released

Posted on July 4, 2004

The Slony-I team is proudly presenting the 1.0 release of the most advanced replication solution for the most advanced Open Source Database in the world:

http://www.slony.org

The multithreaded replication engine requires the libpq client library to be compiled with --enable-thread-safety on certain operating systems.  Known are thus far Solaris and AIX.  Other operating systems are known to not require this (Linux-X86, FreeBSD-X86, FreeBSD-Alpha, OpenBSD-Sparc64 and OSX).  The configuration script is broken with respect to the --enable-thread-safety switch for Solaris.  Please apply this patch, configure and recompile libpq: threadsafe-libpq-742.diff.gz. We will make patches for 7.3.x available on request.

This post has been migrated from a previous version of the PostgreSQL website. We apologise for any formatting issues caused by the migration.


Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group