Skip site navigation (1) Skip section navigation (2)

pgDesigner 1.2.11 Released

Posted on Sept. 6, 2009

Changes:

NEW: Added driver for version 8.4 of PostgreSQL with some limitations, which were not implemented all the features of this news release.

NEW: Added to the translation into Russian language.

BUG: Given the difficulty of ensuring a complete, syntactically and logically, the values in the fields Default Fields for Tables, Type, and Domain, I found it necessary to disable the function that performs this task in an incomplete, leaving the user to complete autonomy in entering any data. Obviously the real formal check will be made by PostgreSQL when creating objects. The problem was highlighted with the use of keyword CURRENT_DATE as default for a date field, the syntax provides different settings, depending on the version of PostgreSQL used, and not always accepted as valid. For the old projects will require a manual review.

BUG: Fixed a bug that occurs when deleting a table relationship.

BUG: Fixed a problem with the function CSqlPrint(), which is not properly constructed queries containing the syntax "CHECK()" for fields in tables.

NDA: Program compiled with version 2.15.2 of Gambas.

For the execution of the program it is necessary to install gambas2 package. Can download gambas from the official site http://gambas.sourceforge.net.

The documentation is available here: http://pgdesigner.sourceforge.net

Last version of pgDesigner is available here: http://sourceforge.net/projects/pgdesigner.

For the customers of Italian language the forum is also available on http://www.ldrweb.net.

This post has been migrated from a previous version of the PostgreSQL website. We apologise for any formatting issues caused by the migration.


Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group